UNIVERSIDAD TÉCNICA DE AMBATO
Ejercicio Nº1
Crear un algoritmo utilizando diagramas de flujo para describirlas actividades...
Ejercicio Nº 2
Ingresar dos números y sacar un mensaje que diga cuales es mayor.
INICIO
a>b
a=0
b=0
a b
INICIO
Ejercicio Nº3
Realizar un algoritmo que permita obtener el sueldo liquidode un trabajadorcon el
descuento del IESS 9.35%
Ejercicio Nº 4
Realizar un algoritmo para obtener el IVA de una venta, si la venta es superior a
$2.000 aplicar un descuen...
Ejercicio Nº 5
Realizar un algoritmo para ingresar el nombre y edad de cualquier persona, imprima
solo si la persona es ma...
Ejercicio Nº 6
Realizar el diagrama de flujo para ingresar un valor en una variable a través del
teclado e imprima por pan...
Ejercicio Nº 7
Calcular la longitud de una circunferencia y el área del círculo que limita dada la
longitud de su radio.
Ejercicio Nº 8
Confeccione un diagrama de flujo que lea un número y si este es mayor o igual a 10,
devuelva en mensaje el ...
CICLO MIENTRAS
Ejercicio Nº 9
REALIZAR UN PROGRAMA QUE LE PERMITA INGRESAR 10 NOTAS Y OBTENER SU
PROMEDIO.
Ejercicio Nº 10
DISEÑA EL ALGORITMO DEL PROGRAMA QUE SUME Y MUETRE EN PANTALLA LOS
MULTIPLOS DE 3 ENTRE 3 Y 99.
Ejercicio Nº 11
Ejercicio Nº 12
Se requiere el algoritmo para elaborar la planillade un empleado.
Para ello se dispone de sus horas labora...
PSUEDOCODIGOS
Ejercicio Nº 13
Ejercicio 1
REALIZARUN PROGRAMA QUE LE PERMITA INGRESAR10 NOTASY OBTENER SU PROMEDIO.
EN PSU...
CASOCONTRARIO
ESCRIBIR“Es menorde Edad” a
FINSI
FIN
Ejercicio Nº 15
Obtener la factorial de un número ingresado por teclad...
Ejercicio Nº 16
ALGORITMO: Numero_Primo
VARIABLES:
Enteros,N,I, n,A,B, a
INICIO
LEER n
MIENTRAS I<n
I=I+1
A=0
B=0
MIENTRAS...
Portafolio uta programación 1
Portafolio uta programación 1
of 17

Portafolio uta programación 1

Portafolio
Published on: Mar 6, 2016
Published in: Engineering      
Source: www.slideshare.net


Transcripts - Portafolio uta programación 1

  • 1. UNIVERSIDAD TÉCNICA DE AMBATO Ejercicio Nº1 Crear un algoritmo utilizando diagramas de flujo para describirlas actividades que realizo para llegar a la universidad. INICIO DESPERTARCE LEVANTARSE IR AL BAÑO DESAYUNAR SALIR DE LA CASA SALGO TEMPRANO TAXI BUS NO SI LLEGAR A LA U FIN
  • 2. Ejercicio Nº 2 Ingresar dos números y sacar un mensaje que diga cuales es mayor. INICIO a>b a=0 b=0 a b INICIO
  • 3. Ejercicio Nº3 Realizar un algoritmo que permita obtener el sueldo liquidode un trabajadorcon el descuento del IESS 9.35%
  • 4. Ejercicio Nº 4 Realizar un algoritmo para obtener el IVA de una venta, si la venta es superior a $2.000 aplicar un descuento del 25%.
  • 5. Ejercicio Nº 5 Realizar un algoritmo para ingresar el nombre y edad de cualquier persona, imprima solo si la persona es mayor de edad el nombre de la persona y si no un mensaje que diga menor de edad.
  • 6. Ejercicio Nº 6 Realizar el diagrama de flujo para ingresar un valor en una variable a través del teclado e imprima por pantalla el numero sin es mayor que cero y si el número es par o impar sino es mayor que cero indicarlo por mensaje.
  • 7. Ejercicio Nº 7 Calcular la longitud de una circunferencia y el área del círculo que limita dada la longitud de su radio.
  • 8. Ejercicio Nº 8 Confeccione un diagrama de flujo que lea un número y si este es mayor o igual a 10, devuelva en mensaje el triple de este, de lo contrario la cuarta parte de este.
  • 9. CICLO MIENTRAS Ejercicio Nº 9 REALIZAR UN PROGRAMA QUE LE PERMITA INGRESAR 10 NOTAS Y OBTENER SU PROMEDIO.
  • 10. Ejercicio Nº 10 DISEÑA EL ALGORITMO DEL PROGRAMA QUE SUME Y MUETRE EN PANTALLA LOS MULTIPLOS DE 3 ENTRE 3 Y 99.
  • 11. Ejercicio Nº 11
  • 12. Ejercicio Nº 12 Se requiere el algoritmo para elaborar la planillade un empleado. Para ello se dispone de sus horas laboradas en el mes así como el del valor que gana por hora cuál será su sueldo que recibe.
  • 13. PSUEDOCODIGOS Ejercicio Nº 13 Ejercicio 1 REALIZARUN PROGRAMA QUE LE PERMITA INGRESAR10 NOTASY OBTENER SU PROMEDIO. EN PSUEDOCODIGO ALGORITMO: Promedio VARIABLES: Enteros,c, n, sum,prom. INICIO MIENTRAS C<=0 HACER LEER n Sum=sum+n c=c+1 FIN MIENTRAS Prom=prom/10 ESCRIBIRprom FIN EJERCICIO 2 Ejercicio Nº 14 INGRESARPOR TECLADO EL NOMBRE Y LA EDAD DE CUALQUIER PERSONA E IMPRIMIR EL NOMBRE DE DICHA PERSONA SOLOSI ES MAYOR DE EDAD ALGORITMO Nombre_Edad VARIABLES Alfabéticasa Enteros b INICIO LEER a , b SI b>18 ESCRIBIRa
  • 14. CASOCONTRARIO ESCRIBIR“Es menorde Edad” a FINSI FIN Ejercicio Nº 15 Obtener la factorial de un número ingresado por teclado. Algoritmo: Num_Factorial Variables: enteros, a , b Inicio Escribir: “Ingrese un número” Leer: a MIENTRASa>0 b=b*a a=a-1 FIN MIENTRAS ESCRIBIR: “El factorial es:”, b
  • 15. Ejercicio Nº 16 ALGORITMO: Numero_Primo VARIABLES: Enteros,N,I, n,A,B, a INICIO LEER n MIENTRAS I<n I=I+1 A=0 B=0 MIENTRAS (A<I) A=A+1 SI (Imod A=0) B=B+1 A=A+1 CASOCONTRARIO A=A+1 FIN SI FIN MIENTRAS SI (B>2) I=I+1 B=B+1 A=A+1 CASOCONTRARIO “Son númerosprimos:“,I I=I+1 FIN SI FIN MIENTRAS FIN

Related Documents